サポート

ホーム  サポート  各種アプリケーション  EC-CUBE

各種アプリケーション EC-CUBEの設定 (MT-4.2)    

EC-CUBEはカスタマイズ性豊かな独自のショッピングプラットフォームが構築できる日本発のオープンソースです。
プチプランはデータベース(MySQL、PostgreSQL)が使えない為、 EC-CUBEはご利用になれません。

注意

【重要: EC-CUBE 一部のバージョンの脆弱性について】
※各バージョン毎の脆弱性についてと対処方法は公式ページのEC-CUBE 脆弱性一覧をご確認下さい。

●【NEW】2013-05-22 脆弱性リストが更新されました。

<2.11.0以降(2.11.0 〜2.12.3) をご利用のお客様>
(1)危険度:高  パスワードリマインド機能における不適切な入力確認の脆弱性
(2)危険度:高  一部環境における、管理画面の不適切な認証に関する脆弱性
(3)危険度:中  カート画面でのXSS脆弱性、及びセッション固定の脆弱性
(4)危険度:中  お届け先複数指定画面でのXSS脆弱性


<2.4.0 RC1 以降 〜 2.12.2未満をご利用のお客様>
危険度:高  顧客情報漏洩の脆弱性の修正方法はこちら

<2.3.2未満をご利用のお客様>
EC-CUBE 2.3.2未満は、2008年10月1日時点でSQLインジェクションの脆弱性が見つかっております。
EC-CUBE 2.3.2未満のものをご利用のお客様は、「SC_Query.zip」ファイルの修正版の入手・アップ
ロードを行う必要がございます。(EC-CUBE 2.3.3以降をご利用の場合、この作業は必要ありません。)

   「SC_Query.zip」ファイルの修正版を入手・アップロード
   1. 以下のサイトにアクセスし、「SC_Query.zip」ファイルをダウンロードします。
     SQLインジェクションの脆弱性についての詳細・修正ファイルのダウンロード
   2. 「SC_Query.zip」ファイルを解凍すると、「SC_Query.php」というファイルができます。
   3. 「SC_Query.php」ファイルを eccube/data/class/SC_Query.php に上書きしてアップロードします。

Movable Type(ブログ)のインストール方法

● ver.2.12 のご利用について

  「EC-CUBE ver.2.12」をご利用の場合は、PostgreSQL データベースをご利用下さい。
  ※弊社のMySQLデータベースではInnoDB形式を有効化していないため、MySQLでは動作しません。


● ver.2.11 のご利用について

 旧バージョン(EC-CUBE ver.2.11)は MySQL/PostgreSQL どちらのデータベースでもインストール可能です。


バージョン 利用方法・解説 対応データベース 補足
ver. 2.12 ver.2.12 のインストール方法 MySQL ×
PostgreSQL ○
プチプラン ×
ver. 2.11 ver.2.11 のインストール方法 MySQL ○
PostgreSQL ○
プチプラン ×


  ※プチプランはデータベース(MySQL、PostgreSQL)が使えない為、 EC-CUBEはご利用になれません。

ページTOP

  

ABLENETのVPS|WindowsServerも試用可能なスケーラブルVPS

  • お問い合わせトップ
  • 障害、メンテナンス情報
  • 掲載禁止、利用禁止事項
  • 他社からの移転について
  • コントロールパネル
  • ホームページ公開までの流れ
  • FTP(ファイルの転送方法)の設定
  • メールソフトの設定
  • CGI・SSI(サーバー環境・設定情報)
  • .htaccessについて
  • 各種アプリケーション
  • ウィルス対策情報

新規お申し込みはコチラから お見積り お申し込み

  • お申し込み〜ご利用までの流れ
  • 旧サーバーからの移転について
  • リンク集
  • 導入実績
  • 独自ドメイン
  • ABLENET レンタルサーバー用語集

12th Anniversary お蔭様で2015年、当社は設立17周年!
これからもABLENETレンタルサーバーは皆様の信頼にお応えし続けます!